
Вопрос задан 22.06.2023 в 01:56.
Предмет Информатика.
Спрашивает Кузнецов Паша.
Составить программу (Паскаль). Ввести число. Если оно больше 45, разделить его на 2, если меньше
или равно 10, то умножить на 5.

Ответы на вопрос

Отвечает Кисловская Ульяна.
Ответ:
program qq;
var
n : integer;
begin
readln(n); //Вводим число
if n > 45 then //Если оно больше 45 то
writeln((n / 2):0:3); //Выводим число делённое на 2
if n <= 45 then //Если меньше или равно
writeln(n * 5); //Выводим n * 5;
end.
Писал на fpc



Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Вот пример программы на языке Паскаль, которая выполняет задачу, описанную в вашем вопросе:
pascalprogram Main; var num: integer; begin writeln('Введите число: '); readln(num); if num > 45 then begin num := num div 2; end else if num <= 10 then begin num := num * 5; end; writeln('Результат: ', num); end.
Эта программа сначала запрашивает у пользователя ввод числа, затем проверяет его значение. Если число больше 45, оно делится на 2, а если число меньше или равно 10, то оно умножается на 5. Результат выводится на экран.


Похожие вопросы

Информатика 75

Информатика 92

Информатика 43

Информатика 62

Информатика 37

Информатика 21

Информатика 85

Информатика 27
Топ вопросов за вчера в категории Информатика

Информатика 47

Информатика 33

Информатика 67

Информатика 18

Информатика 25

Информатика 563

Информатика 16
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili