
Нужно написать программу, где вызывается функция, выводящее первое простое число в указанном
диапазоне. Нужно ввести начало и конец диапазона. Если в указанном диапазоне нет ни одного простого числа, программа должнв выдать сообщение There is no prime На языке с++

Ответы на вопрос

Ответ:
#include <iostream>
#include <cmath>
using namespace std;
bool is_prime_num(int x) {
for(long long i=2 ; i <= sqrt(x); i++)
if( x % i == 0)
return false;
return true;
}
int main()
{
int arr[10000];
int n;
cin >> n; // вводим кол-во элементов массива
for (int i = 0; i < n; i++) {
cin >> arr[i]; // вводим элементы массива n раз
}
int a,b;
cin >> a >> b; // вводим границы диапазона
int result = 0;
for (int i = a; a < b; i++) {
if (is_prime_num(arr[i])) {
result = arr[i];
break;
}
}
if ( result == 0) cout << "There is no prime";
else cout << result;
return 0;
}
Объяснение:
Как - то так, если что непонятно - спрашивай



Конечно, вот пример программы на C++, которая находит первое простое число в заданном пользователем диапазоне:
cpp#include <iostream>
bool isPrime(int number) {
if (number <= 1) {
return false;
}
for (int i = 2; i * i <= number; ++i) {
if (number % i == 0) {
return false;
}
}
return true;
}
int findFirstPrime(int start, int end) {
for (int i = start; i <= end; ++i) {
if (isPrime(i)) {
return i;
}
}
return -1; // возвращаем -1, если в указанном диапазоне нет простых чисел
}
int main() {
int start, end;
std::cout << "Введите начало диапазона: ";
std::cin >> start;
std::cout << "Введите конец диапазона: ";
std::cin >> end;
int firstPrime = findFirstPrime(start, end);
if (firstPrime != -1) {
std::cout << "Первое простое число в диапазоне: " << firstPrime << std::endl;
} else {
std::cout << "Простых чисел в указанном диапазоне нет." << std::endl;
}
return 0;
}
Просто скопируйте этот код в файл с расширением .cpp
и скомпилируйте его с помощью компилятора C++, чтобы выполнить программу.


Похожие вопросы







Топ вопросов за вчера в категории Информатика







Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili