Вопрос задан 21.06.2023 в 16:27. Предмет Информатика. Спрашивает Абрамова Катя.

Напишите программу, которая будет запрашивать у пользователя число N, генерировать N случайных

чисел в диапазоне от 1 до 50, для каждого сгенерированного случайного числа вычислять сумму от 1 до этого числа и печатать табличку чисел и сумм. Программа на питоне
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Гілецький Роман.

Ответ:

Объяснение:

Python

from random import randint

def getsum(a):

   s=0

   for i in range (1,a+1):

      s+=i

   return s    

n=int(input('Введите n: '))

a=[randint(1,50) for i in range(n)]

for i in range (0, n):

  print(a[i], ' сумма =',getsum(a[i]))


0 0
Отвечает Филюшин Николай.

Ответ:

Объяснение:

В конце всё ужасно некрасиво получилось, но я начинающий, так что таблицы еще знать не знаю.

Если что-то непонятно, пиши



0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, вот пример программы на Python, которая выполняет указанные действия:

python
import random # Запрос числа N от пользователя N = int(input("Введите число N: ")) # Генерация N случайных чисел в диапазоне от 1 до 50 и вычисление суммы print("Число\tСумма от 1 до числа") for _ in range(N): random_number = random.randint(1, 50) sum_of_numbers = sum(range(1, random_number + 1)) print(f"{random_number}\t{sum_of_numbers}")

Эта программа сначала запрашивает у пользователя число N, затем генерирует N случайных чисел в диапазоне от 1 до 50 и для каждого числа вычисляет сумму от 1 до этого числа. Результаты выводятся в виде таблички чисел и сумм.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос