Вопрос задан 21.06.2023 в 14:42. Предмет Информатика. Спрашивает Демковський Назар.

Python Напишите программу, которая запрашивает у пользователя число до тех пор, пока он не введет

цифру 0. Программа должна посчитать сумму всех положительных чисел. Также создайте словарь my_dict и добавьте туда, все отрицательные числа кратные 3, ключом долженбыть порядковый номер, под которым было введено это число.мне нужен ток вот это часть:Также создайте словарь my_dict идобавьте туда, все отрицательные числа кратные 3, ключом долженбыть порядковый номер, под которым было введено это число.я не знаю как так добавить в словар​
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Аутов Ренат.

Ответ:

Объяснение:

Т.к. я не знаю, как ты реализовал первую часть программы, скидываю тебе своё решение этой задачи целиком:

numbers_list = []

while True:

   numbers = int(input("Введите число: "))

   if numbers == 0:

       break

   else:

       numbers_list.append(numbers)

sum_numbers = sum(numbers_list)

my_dict = {}

for x, y in enumerate(numbers_list):

   if y % 3 == 0:

       my_dict[x] = y  # Замени на my_dict[x+1] = y, если надо считать с 1

print(f"Сумма всех введенных чисел: {sum_numbers}")

print(f"Словарь из чисел, кратных 3: {my_dict}")

Значит, смотри:

Создаём пустой лист. Далее вводим числа в бесконечном цикле, пока не получим 0 и складываем их в лист.

Затем, получаем сумму всех чисел при помощи функции sum().

Потом создаём пустой словарик. И в цикле перебираем наш список с цифрами, используя enumerate (), чтобы получать индекс этого числа (то бишь, порядковый номер). Обрати внимание, что номер будет начинаться с нуля. Т.е. если тебе надо с 1, то просто в my_dict[x] = y поменяй на my_dict[x+1] = y и всё.

Ну и проходясь по списку с числами, мы проверяем каждое число, делится ли оно на 3 и если да, то добавляем в словарь. Где его ключ - это индекс, а значение - само число.

Пример работы программы, разумеется, прилагаю.


0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Вы можете создать словарь my_dict и добавлять в него отрицательные числа, кратные 3, используя порядковый номер ввода в качестве ключа. Вот пример программы:

python
my_dict = {} # Создаем пустой словарь # Инициализируем переменные sum_positive = 0 count = 1 while True: user_input = int(input("Введите число (для завершения введите 0): ")) if user_input == 0: break if user_input > 0: sum_positive += user_input elif user_input % 3 == 0: my_dict[count] = user_input count += 1 # Выводим результаты print("Сумма положительных чисел:", sum_positive) print("Словарь my_dict с отрицательными числами, кратными 3:", my_dict)

Этот код будет продолжать запрашивать числа до тех пор, пока пользователь не введет 0. Положительные числа будут суммированы в sum_positive, а отрицательные числа, кратные 3, будут добавлены в словарь my_dict с использованием порядкового номера count в качестве ключа.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос