
С++ Даны два массива a и b одинаковой длины n. Создать новый массив длины 2n, в котором все
элементы с чётными индексами заимствуются из массива a, а с нечётными индексами из b. Формат входных данных С клавиатуры вводится натуральное число n (n≤100) — размер массивов. Во второй и третьей строках вводятся по n элементов массивов через пробел. Все элементы не превосходят по модулю 100000. Формат выходных данных Необxодимо вывести 2n элементов нового массива. входные данные 5 1 2 3 4 5 5 4 3 2 1 выходные данные 1 5 2 4 3 3 4 2 5 1

Ответы на вопрос

Ответ: держи
#include <iostream>
using namespace std;
int main()
{
int n, i;
cout << "n = ";
cin >> n;
int a[n], b[n], c[2 * n], ac = 0, bc = 0;
cout << "введите а: ";
for (i = 0; i < n; i++) {
cin >> a[i];
}
cout << "введите b: ";
for (i = 0; i < n; i++) {
cin >> b[i];
}
cout << endl;
for (i = 0; i < 2 * n; i++) {
if (i % 2 == 0) { // парное
c[i] = a[ac];
ac++;
}
else { // непарное
c[i] = b[bc];
bc++;
}
cout << c[i] << ' ';
}
return 0;
}



Для решения этой задачи вам нужно сначала прочитать входные данные, затем создать новый массив, заполнив его элементами из массивов a и b в соответствии с заданными правилами, и, наконец, вывести результат. Вот C++ код, который делает это:
cpp#include <iostream>
int main() {
int n;
std::cin >> n;
int a[n], b[n], result[2 * n];
for (int i = 0; i < n; i++) {
std::cin >> a[i];
}
for (int i = 0; i < n; i++) {
std::cin >> b[i];
}
for (int i = 0; i < n; i++) {
result[2 * i] = a[i]; // Элементы с четными индексами берутся из массива a
result[2 * i + 1] = b[i]; // Элементы с нечетными индексами берутся из массива b
}
for (int i = 0; i < 2 * n; i++) {
std::cout << result[i] << " ";
}
return 0;
}
Вы можете скомпилировать и запустить этот код, и вводить ваши данные. Он сначала считывает n, затем элементы массивов a и b, создает новый массив result и заполняет его соответственно. В конце выводится новый массив в нужном формате.



Вот пример решения этой задачи на C++:
cpp#include <iostream>
using namespace std;
int main() {
int n;
cin >> n;
int a[n], b[n], result[2 * n];
// Ввод элементов массивов a и b
for (int i = 0; i < n; i++) {
cin >> a[i];
}
for (int i = 0; i < n; i++) {
cin >> b[i];
}
// Создание нового массива result
for (int i = 0; i < n; i++) {
result[2 * i] = a[i]; // Элементы с чётными индексами из массива a
result[2 * i + 1] = b[i]; // Элементы с нечётными индексами из массива b
}
// Вывод нового массива
for (int i = 0; i < 2 * n; i++) {
cout << result[i] << " ";
}
return 0;
}
Вы можете скопировать и вставить этот код в свою среду разработки C++ и выполнить его, чтобы получить ожидаемый результат.


Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili