
Составить программу (полный текст программы) вычисления стоимости покупки с учетом скидки. Скидка в
3% предоставляется, если сумма покупки больше 500 руб, в 5% - если сумма больше 1000 руб. Фрагмент программы: if x>500 then y:=0.97*x; if x>1000 then y:=0.95*x;

Ответы на вопрос

var
x: real;
begin
readln(x);
if(x > 500) then x := 0.97 * x
else if(x > 1000) then x := 0.95 * x;
writeln('Стоимость покупки с учетом скидки: ', x);
end.



Да, конечно! Пример программы на языке Pascal, который вы написали, выглядит как начало условной конструкции, но не содержит полной программы. Давайте дополним этот фрагмент и создадим полную программу.
```pascal program CalculateDiscount; var purchaseAmount, discountedAmount: real;
begin // Ввод суммы покупки write('Введите сумму покупки в рублях: '); readln(purchaseAmount);
// Проверка условий для применения скидки if purchaseAmount > 500 then discountedAmount := 0.97 * purchaseAmount // Скидка 3% else if purchaseAmount > 1000 then discountedAmount := 0.95 * purchaseAmount // Скидка 5% else discountedAmount := purchaseAmount; // Без скидки
// Вывод результата writeln('Сумма покупки без скидки: ', purchaseAmount:0:2, ' руб.'); writeln('Сумма покупки с учетом скидки: ', discountedAmount:0:2, ' руб.');
readln; // Задержка перед закрытием консоли (для Windows) end. ```
Эта программа запрашивает у пользователя сумму покупки, проверяет условия для применения скидки и выводит итоговую сумму с учетом скидки.


Топ вопросов за вчера в категории Информатика







Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili