
Вопрос задан 24.03.2019 в 20:08.
Предмет Информатика.
Спрашивает Ахметов Имран.
Задача на c++ Даны два массива a и b одинаковой длины n. Создать новый массив длины 2n, в котором
все элементы с чётными индексами заимствуются из массива a, а с нечётными индексами из b. Индексы массивов начинаются с 0. Формат входных данных С клавиатуры вводится натуральное число n (n≤100) — размер массивов. Во второй и третьей строках вводятся по nn элементов массивов через пробел. Все элементы не превосходят по модулю 10000. Формат выходных данных Необxодимо вывести 2n элементов нового массива. Примеры входные данные 5 1 2 3 4 5 5 4 3 2 1 выходные данные 1 5 2 4 3 3 4 2 5 1

Ответы на вопрос

Отвечает Кравчук Илья.
/* C++ 17 */
#include <iostream>
using namespace std;
int main()
{
int n, i;
cout << "n = ";
cin >> n;
int a[n], b[n], c[2 * n], ac = 0, bc = 0;
cout << "введите а: ";
for (i = 0; i < n; i++) {
cin >> a[i];
}
cout << "введите b: ";
for (i = 0; i < n; i++) {
cin >> b[i];
}
cout << endl;
for (i = 0; i < 2 * n; i++) {
if (i % 2 == 0) { // парное
c[i] = a[ac];
ac++;
}
else { // непарное
c[i] = b[bc];
bc++;
}
cout << c[i] << ' ';
}
return 0;
}
#include <iostream>
using namespace std;
int main()
{
int n, i;
cout << "n = ";
cin >> n;
int a[n], b[n], c[2 * n], ac = 0, bc = 0;
cout << "введите а: ";
for (i = 0; i < n; i++) {
cin >> a[i];
}
cout << "введите b: ";
for (i = 0; i < n; i++) {
cin >> b[i];
}
cout << endl;
for (i = 0; i < 2 * n; i++) {
if (i % 2 == 0) { // парное
c[i] = a[ac];
ac++;
}
else { // непарное
c[i] = b[bc];
bc++;
}
cout << c[i] << ' ';
}
return 0;
}


Топ вопросов за вчера в категории Информатика

Информатика 558

Информатика 33

Информатика 74

Информатика 12

Информатика 10

Информатика 33

Информатика 27
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili