Вопрос задан 20.06.2023 в 11:29. Предмет Информатика. Спрашивает Халыкбай Арайлым.

Условие: Требуется написать программу которая в исходном трехзначном числе x меняют местами цифры

сотен и десятков, единицы оставляет в исходном состоянии выводит полученное число. Формат входных данных:Входной поток содержит целое число (100< x <999)Формат выходных данных:Программа должна вывести трехзначное число - результат указанной перестановки цифр в числе x. ​
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Куропата Максим.

Программа написана на языке C# (.NET Framework)

- Если число должно выдаваться пользователем:

using System;

namespace ConsoleApp2

{

class Program

{

static void Main(string[] args)

{

while (true)

{

int o = Int32.Parse(Console.ReadLine());

if (o < 100 || o > 999)

{

Console.WriteLine("Ошибка!");

Console.ReadLine();

}

else

{

int a = o / 100,

b = (o / 10) % 10,

c = o % 10;

String x = Convert.ToString(b) + Convert.ToString(a) + Convert.ToString(c);

Console.WriteLine(x);

Console.ReadLine();

}

}

}

}

}

- Если число должно выдаваться с запуском программы:

using System;

namespace ConsoleApp2

{

class Program

{

static void Main(string[] args)

{

while (true)

{

Random rnd = new Random();

int o = rnd.Next(100, 999),

a = o / 100,

b = (o / 10) % 10,

c = o % 10;

String x = Convert.ToString(b) + Convert.ToString(a) + Convert.ToString(c);

Console.WriteLine(o);

Console.WriteLine(x);

Console.ReadLine();

}

}

}

}

}

0 1
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Вот пример программы на языке Python, которая решает задачу:

python
# Считываем входные данные x = int(input()) # Получаем цифры сотен, десятков и единиц hundreds = x // 100 tens = (x // 10) % 10 units = x % 10 # Меняем местами цифры сотен и десятков result = tens * 100 + hundreds * 10 + units # Выводим результат print(result)

Пример работы программы:

Входные данные: 345 Выходные данные: 435

Программа сначала считывает трехзначное число, затем разбивает его на цифры сотен, десятков и единиц. После этого меняет местами цифры сотен и десятков, оставляя единицы в исходном порядке, и выводит полученное число.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос