
Нужно написать программу на языке паскаль. С клавиатуры вводятся длины сторон К прямоугольников.
Посчитать количество вертикально расположенных и количество горизонтально расположенных прямоугольников, исходя из того, что сторона А всегда параллельна оси Х, а сторона В - оси У.

Ответы на вопрос

var
a,b,k,i,k1:integer;
begin
write('Сколько фигур: '); readln(k);
b:=0; k1:=0;
for i:=1 to k do
begin
write('Стороны ',i,'-го треугольника(A B): '); readln(a,k);
if a>=k then
if a>k then
inc(b)
else inc(k1);
end;
writeln('Горизонтальных: ',b);
writeln('Вертикальных: ',i-b-k1);
if k1<>0 then
writeln('Квадратов: ',k1);
end.
Если моё решение помогло вам, пометьте его лучшим. Спасибо!



Я попробую помочь вам с написанием программы на языке Паскаль. Вот один из возможных вариантов решения вашей задачи:
{$CODEPAGE UTF8} program CountRectangles; var n, i, a, b, vertical, horizontal: integer; begin write('Введите количество прямоугольников: '); readln(n); vertical := 0; // счетчик вертикальных прямоугольников horizontal := 0; // счетчик горизонтальных прямоугольников for i := 1 to n do begin write('Введите длину стороны A прямоугольника ', i, ': '); readln(a); write('Введите длину стороны B прямоугольника ', i, ': '); readln(b); if a > b then // если сторона A больше стороны B, то прямоугольник вертикальный vertical := vertical + 1 else if a < b then // если сторона A меньше стороны B, то прямоугольник горизонтальный horizontal := horizontal + 1; // если стороны A и B равны, то прямоугольник квадратный и не учитывается end; writeln('Количество вертикальных прямоугольников: ', vertical); writeln('Количество горизонтальных прямоугольников: ', horizontal); readln; end.
Эта программа считывает с клавиатуры количество прямоугольников и длины их сторон A и B. Затем она сравнивает эти длины и определяет, какой прямоугольник является вертикальным, а какой горизонтальным. В конце она выводит на экран количество вертикальных и горизонтальных прямоугольников.
Надеюсь, это поможет вам. Если у вас есть еще вопросы, я буду рад ответить на них.


Похожие вопросы
Топ вопросов за вчера в категории Информатика







Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili