Написать программу на языке паскаль. С клавиатуры вводятся длины сторон К прямоугольников.
Посчитать количество вертикально расположенных и количество горизонтально расположенных прямоугольников, исходя из того, что сторона А всегда параллельна оси Х, а сторона В - оси У.Ответы на вопрос
Если не правильно извини

Программа на языке Паскаль:
```pascal program RectangleCount; var A, B, verticalCount, horizontalCount: integer; begin verticalCount := 0; horizontalCount := 0; writeln('Введите длины сторон прямоугольников (для завершения введите 0 0):'); repeat readln(A, B); if (A = 0) and (B = 0) then break; if A > B then verticalCount := verticalCount + 1 else horizontalCount := horizontalCount + 1; until (A = 0) and (B = 0); writeln('Количество вертикально расположенных прямоугольников: ', verticalCount); writeln('Количество горизонтально расположенных прямоугольников: ', horizontalCount); end. ```
Эта программа сначала инициализирует переменные для хранения количества вертикально и горизонтально расположенных прямоугольников. Затем программа запрашивает у пользователя ввод длин сторон прямоугольников и подсчитывает количество вертикально и горизонтально расположенных прямоугольников, используя условный оператор. После ввода нулевых значений программа выводит количество вертикально и горизонтально расположенных прямоугольников.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
