Вопрос задан 20.06.2023 в 05:00. Предмет Информатика. Спрашивает Шайсламова Лия.

Написать программу нахождения функции у=(х+5)/(х-7) На языке паскаль Как в компьютере вводим типо

programm tt; И т.п, прошу И блок схему если есть возможность прикрепить Даю 50 баллов Заранее спасибо!
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Nigmatullin Islam.

program restless;

var

y, x : real;

begin

readln(x);

if x <> 7 then

   begin

   y := (x+5)/(x-7);

   writeln(y:5:2);

   end

else

   writeln('Возникло деление на 0!');

end.


0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Программа нахождения функции у=(х+5)/(х-7) на языке Паскаль

Для написания программы на языке Паскаль, которая будет находить значение функции у=(х+5)/(х-7), можно использовать следующий код:

```pascal program FunctionCalculation;

var x, y: real;

begin writeln('Введите значение x:'); readln(x);

if x = 7 then begin writeln('Значение x не может быть равно 7, так как это приведет к делению на ноль.'); end else begin y := (x + 5) / (x - 7); writeln('Значение функции y = (x + 5) / (x - 7) при x = ', x, ' равно ', y:0:2); end; readln; end. ```

В этой программе мы сначала запрашиваем у пользователя значение переменной x. Затем мы проверяем, равно ли значение x 7. Если да, то выводим сообщение о том, что значение x не может быть равно 7, так как это приведет к делению на ноль. Если значение x не равно 7, то мы вычисляем значение функции y=(x+5)/(x-7) и выводим его на экран.

Блок-схема программы

Если у вас есть возможность прикрепить блок-схему, это может помочь визуализировать логику программы. Однако, в данном случае, блок-схема не была предоставлена в поисковых результатах.

Надеюсь, эта информация поможет вам написать программу на языке Паскаль для нахождения значения функции у=(х+5)/(х-7). Если у вас возникнут дополнительные вопросы, не стесняйтесь задавать их!

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос