Помогите пожалуйста!! Pascal. На вход программе подается `3` числа: номер дня в месяце, номер
месяца и год. Вывести номер дня недели (`1`– понедельник, `7`–воскресенье) соответствующего этой дате.Ответы на вопрос
Ответ:
Объяснение:
var
d, m, y, w, a: longint;
begin
readln(d, m, y);
a := (14 - m) div 12;
y := y - a;
m := m + 12 * a - 2;
w := (d + 31 * m div 12 + y + y div 4 - y div 100 + y div 400 + 6) mod 7 + 1;
writeln(w);
readln
end.
Для решения данной задачи вам потребуется использовать алгоритм, который будет преобразовывать введенную дату в номер дня недели. В языке программирования Pascal вы можете использовать функцию `DayOfWeek`, которая возвращает номер дня недели для заданной даты.
Вот пример кода на Pascal, который решает данную задачу:
```pascal program DayOfWeek; var day, month, year: Integer; dayOfWeek: Integer; begin // Ввод даты WriteLn('Введите день:'); ReadLn(day); WriteLn('Введите месяц:'); ReadLn(month); WriteLn('Введите год:'); ReadLn(year);
// Вычисление номера дня недели dayOfWeek := DayOfWeek(EncodeDate(year, month, day));
// Вывод результата WriteLn('Номер дня недели:', dayOfWeek); end. ```
В этом коде мы сначала запрашиваем у пользователя день, месяц и год. Затем мы используем функцию `DayOfWeek`, чтобы вычислить номер дня недели для заданной даты. Наконец, мы выводим полученный результат.
Примечание: В данном примере мы предполагаем, что у вас уже есть знания о языке Pascal и его синтаксисе. Если у вас возникнут вопросы по коду или его выполнению, пожалуйста, задайте их, и я с удовольствием помогу вам разобраться.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
