Написать программу в паскль которая вводит с клавиатуры одномерный массив из 10 целых чисел и
вычисляет: количество элементов массива значение которых равно единицеОтветы на вопрос
Программа:
Pascal:
var
arr: array[1..10] of integer;
i, n: integer;
begin
writeln('Введите массив из 10 чисел:');
for i := 1 to 10 do begin
readln(arr[i]);
if arr[i] = 1 then inc(n);
end;
writeln('Введено ', n, ' единиц(-а).');
end.
Программа на Pascal, которая вводит с клавиатуры одномерный массив из 10 целых чисел и вычисляет количество элементов массива, значение которых равно единице, может выглядеть следующим образом:
```pascal program CountOnes;
var arr: array[1..10] of Integer; i, count: Integer;
begin count := 0; // Ввод массива с клавиатуры for i := 1 to 10 do begin Write('Введите элемент массива arr[', i, ']: '); ReadLn(arr[i]); end; // Подсчет количества элементов со значением 1 for i := 1 to 10 do begin if arr[i] = 1 then count := count + 1; end; // Вывод результата WriteLn('Количество элементов массива со значением 1: ', count); ReadLn; end. ```
В этой программе мы объявляем массив `arr` из 10 целых чисел и переменные `i` и `count`, где `i` используется для итераций в циклах, а `count` для подсчета количества элементов со значением 1.
Затем мы с помощью цикла `for` заполняем массив `arr` вводом значений с клавиатуры.
Далее используется еще один цикл `for`, чтобы пройти по всем элементам массива и проверить, равен ли текущий элемент 1. Если это так, то увеличиваем значение переменной `count` на 1.
В конце программы выводится результат - количество элементов массива со значением 1.
Надеюсь, это поможет!
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
