Вопрос задан 18.06.2023 в 04:16. Предмет Информатика. Спрашивает Мухаметьярова Лера.

(Python) 1) Составить программу циклического заполнения целочисленного массива REW, состоящего из

100 элементов случайными значениями в диапазоне от 200 до 500 с выводом массива на экран. 2) Составить программу циклического заполнения массива F, состоящего из 50 элементов строковыми значениями, начиная со значения «кар-», а затем каждый очередной раз увеличивая это значение на «кар-». В итоге, значение 0-ого элемента массива будет «кар-»; значение 1-го элемента - «кар-кар-»; значение 2-го элемента - «кар-кар-кар-» и т.д. Массив вывести на экран.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Забашта Лиля.

Ответ:

1.

import random

REW =[random.randint(200, 500) for i in range(100)]

print(REW)

2.

s = 'кар-'

F = []

for i in range(1, 51):

   F.append(s * i)

print(F)

Объяснение:

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Очень рад помочь! Вот решение вашей задачи на языке Python:

Задача 1: Заполнение целочисленного массива случайными значениями

Для начала, нам понадобится модуль `random`, чтобы генерировать случайные числа. Мы можем использовать функцию `randint` из этого модуля, чтобы получить случайное целое число в заданном диапазоне.

```python import random

# Создаем пустой массив размером 100 REW = [0] * 100

# Заполняем массив случайными значениями в диапазоне от 200 до 500 for i in range(100): REW[i] = random.randint(200, 500)

# Выводим массив на экран print(REW) ```

В этом примере мы создаем пустой массив `REW` размером 100, а затем используем цикл `for` для заполнения его случайными значениями в диапазоне от 200 до 500. Затем мы выводим массив на экран с помощью функции `print`.

Задача 2: Заполнение массива строковыми значениями

Для этой задачи нам не понадобится модуль `random`, но мы будем использовать цикл `for` для генерации строковых значений.

```python # Создаем пустой массив размером 50 F = [""] * 50

# Задаем начальное значение value = "кар-"

# Заполняем массив строковыми значениями for i in range(50): F[i] = value value += "кар-"

# Выводим массив на экран print(F) ```

В этом примере мы создаем пустой массив `F` размером 50 и задаем начальное значение `value` равным "кар-". Затем мы используем цикл `for` для заполнения массива строковыми значениями, увеличивая значение `value` на "кар-" на каждой итерации. Затем мы выводим массив на экран с помощью функции `print`.

Надеюсь, это поможет вам! Если у вас есть еще вопросы, пожалуйста, дайте мне знать.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос