Вопрос задан 18.06.2023 в 00:37. Предмет Информатика. Спрашивает Шарандин Илья.

Для питона 1. Найдите произведение всех элементов списка с нечетными индексами (то есть A[1],

A[3], A[5], ...). Входные данные Вводится список чисел. Все числа списка находятся на одной строке. Выходные данные Выведите ответ на задачу. 2. Найдите суму всех четных элементов списка. Входные данные Вводится список чисел. Все числа списка находятся на одной строке. Выходные данные Выведите ответ на задачу.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Дуганов Андрей.

Ответ:

1) Числа вводятся через пробел

a = input()

arr = list(map(int, a.split(' ')))

r = 1

for i in range(len(arr)):

   if i % 2 != 0:

       r = r * int(arr[i])

print(r)

2)Числа вводятся через пробел

a = input()

arr = list(map(int, a.split(' ')))

s = 0

for i in range(len(arr)):

   if arr[i] % 2 == 0:

       s += arr[i]

print(s)

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Задача 1: Найдите произведение всех элементов списка с нечетными индексами

Для решения этой задачи вам потребуется выполнить следующие шаги:

1. Введите список чисел. 2. Создайте переменную `product` и присвойте ей значение 1. Эта переменная будет использоваться для хранения произведения элементов списка с нечетными индексами. 3. Используйте цикл `for` для перебора элементов списка с нечетными индексами. В качестве индексов используйте срез `[1::2]`, который выбирает элементы с нечетными индексами. 4. Внутри цикла умножайте текущий элемент списка на значение переменной `product` и присваивайте результат обратно переменной `product`. 5. Выведите значение переменной `product` в качестве ответа на задачу.

Пример решения:

```python numbers = input("Введите список чисел: ").split() product = 1

for num in numbers[1::2]: product *= int(num)

print("Произведение всех элементов списка с нечетными индексами:", product) ```

Задача 2: Найдите сумму всех четных элементов списка

Для решения этой задачи вам потребуется выполнить следующие шаги:

1. Введите список чисел. 2. Создайте переменную `sum_even` и присвойте ей значение 0. Эта переменная будет использоваться для хранения суммы четных элементов списка. 3. Используйте цикл `for` для перебора элементов списка. Внутри цикла проверяйте, является ли текущий элемент четным числом с помощью оператора `%` (остаток от деления на 2). Если элемент четный, добавляйте его к значению переменной `sum_even`. 4. Выведите значение переменной `sum_even` в качестве ответа на задачу.

Пример решения:

```python numbers = input("Введите список чисел: ").split() sum_even = 0

for num in numbers: if int(num) % 2 == 0: sum_even += int(num)

print("Сумма всех четных элементов списка:", sum_even) ```

Обратите внимание: В обоих решениях предполагается, что пользователь будет вводить числа через пробел. Если числа вводятся в другом формате, например, через запятую, вам потребуется изменить код для правильного разделения чисел.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос