Вопрос задан 15.06.2020 в 11:18. Предмет Информатика. Спрашивает Вернер Машуля.

ДЛЯ ПИТОНА Переставьте элементы данного списка в обратном порядке, затем выведите элементы

полученного списка. Эта задача отличается от предыдущей тем, что вам нужно изменить значения элементов самого списка, поменяв местами A[0] c A[n-1], A[1] с A[n-2], а затем вывести элементы списка подряд. Входные данные Вводится список чисел. Все числа списка находятся на одной строке. Выходные данные Выведите ответ на задачу. Примеры входные данные 1 2 3 4 5 выходные данные 5 4 3 2 1
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Субботин Владислав.
A = []
while 1:
    b = input(Введите число.Если хотите выйти напишите n: ")
    if (b == 'n'):
        break
    if b.isdigit():
        a.append(int(b))
a.reverse()
print(a)




 
1 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос