
C++ Даю 100 баллов!! Напишите программу, которая определяет, верно ли, что введённое число
содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число. Выходные данные Программа должна вывести слово 'YES', если в числе есть две одинаковые цифры, стоящие рядом, и слово 'NO', если такой пары цифр нет.

Ответы на вопрос

Программа:
C++:
#include <iostream>
using namespace std;
int main()
{
int num, last, tmp;
bool checkYES = false;
cout << "Введите число: "; cin >> num;
while (num > 0) {
last = num % 10;
tmp = num / 10;
if (tmp % 10 == last) {
cout << "YES";
checkYES = true;
return 1;
}
num /= 10;
}
if (checkYES != true) { cout << "NO"; return 1; }
else return 1;
}



Вот пример программы на языке C++, которая определяет, содержит ли введенное число две одинаковые цифры, стоящие рядом:
```cpp
#include
bool hasAdjacentDigits(int number) { std::string numberString = std::to_string(number); for (int i = 0; i < numberString.length() - 1; i++) { if (numberString[i] == numberString[i + 1]) { return true; } } return false; }
int main() { int number; std::cout << "Введите число: "; std::cin >> number;
if (hasAdjacentDigits(number)) { std::cout << "YES" << std::endl; } else { std::cout << "NO" << std::endl; }
return 0; } ```
Программа сначала считывает число с помощью функции `std::cin`, а затем вызывает функцию `hasAdjacentDigits`, которая проверяет, содержит ли число две одинаковые цифры, стоящие рядом. Функция `hasAdjacentDigits` преобразует число в строку и затем проверяет каждую пару соседних цифр на равенство. Если такая пара найдена, функция возвращает `true`, иначе - `false`.
Пример работы программы: ``` Введите число: 221 YES ```
``` Введите число: 12345 NO ```
Примечание: Данная программа работает только с натуральными числами. Если вам нужно обрабатывать отрицательные числа или числа с десятичной частью, вам потребуется внести соответствующие изменения в код.


Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili