Вопрос задан 17.06.2023 в 14:03. Предмет Информатика. Спрашивает Бохов Альберт.

напишите программу 1) Последовательность изменяется по закону 2,10,18... Сколько элементов

последовательности надо взять, чтобы их сумма была больше 100 2) С клавиатуры вводится 20 чисел. Определите произведение этих чисел, количество положительных, сумму отрицательных элементов срочнооо заранее спасибо​
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Плисов Артем.

Ответ:

Решение на паскале.

Объяснение:

Первая задача:

var summa, kolichestvo : integer;

 begin

   summa := 2;

   while summa <= 100 do

   begin

     summa := summa + 8;

     kolichestvo := kolichestvo + 1;

   end;

   writeln('Количество = ', kolichestvo);

 end.

Вторая задача:

var a : array[1..20] of integer;

   kolpol, sumot, i : integer;

begin

 for i:=1 to 20 do

   Read(a[i]);

 for i := 1 to 20 do

   if a[i] >= 0 then

     kolpol := kolpol +1

   else

     sumot := sumot + a[i];

 writeln('Количество положительных = ', kolpol);

 writeln('Сумма отрицательных = ', sumot);

end.

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

1) Чтобы определить, сколько элементов последовательности нужно взять, чтобы их сумма была больше 100, нужно найти закономерность в изменении элементов и продолжить последовательность до тех пор, пока сумма не превысит 100.

Исходя из данной последовательности, можно заметить, что каждый следующий элемент получается путем добавления 8 к предыдущему элементу. Таким образом, можно продолжить последовательность следующим образом: 2, 10, 18, 26, 34, 42, 50, 58, 66, 74, 82, 90, 98, 106.

В данном случае, чтобы сумма элементов последовательности была больше 100, необходимо взять 14 элементов.

2) Для определения произведения введенных чисел, количества положительных чисел и суммы отрицательных элементов, нужно прочитать 20 чисел с клавиатуры и выполнить соответствующие операции.

Вот пример программы на языке Python, решающ

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос