Вопрос задан 16.06.2023 в 23:59. Предмет Информатика. Спрашивает Зубов Михаил.

Написать программу ввода с клавиатуры двухцелых чисел; вывести среднее арифметическое и квадрат

разности этих чисел паскаль помогите пожалуйстаааааа
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Ивтушенко Мария-Ивановна.

def av(x, y):

   return (x + y) / 2

def sqDiff(x, y):

   return (x - y)**2

a, b = map(int, input().split())

print("Average: " + str(av(a, b)))

print("Square of difference: " + str(sqDiff(a, b)))

0 0
Отвечает Черных Софья.

pascal:

program chislo;

var a, b, d: integer;

c:real;

begin

writeln('Введите первое число: ');

readln(a);

writeln('Введите второе число: ');

readln(b);

d:=(a*a)-((a*2)*b)+(b*b);

writeln('Квадрат разности: ', d);

c:=((a+b)/2);

writeln('Среднее арифметическое: ', round(c));

end.

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, я могу помочь вам со написанием программы для ввода двух целых чисел с клавиатуры, подсчетом их среднего арифметического и квадрата разности этих чисел. Вот пример такой программы на языке Pascal:

```pascal program CalculateAverageAndSquareDifference; var num1, num2, average, difference: integer; begin // Ввод двух целых чисел writeln('Введите первое целое число:'); readln(num1); writeln('Введите второе целое число:'); readln(num2); // Подсчет среднего арифметического average := (num1 + num2) div 2; // Подсчет квадрата разности difference := num1 - num2; difference := difference * difference; // Вывод результатов writeln('Среднее арифметическое:', average); writeln('Квадрат разности:', difference); end. ```

Эта программа сначала запрашивает у пользователя ввод двух целых чисел, затем вычисляет среднее арифметическое и квадрат разности этих чисел. Результаты выводятся на экран.

Надеюсь, это поможет вам! Если у вас есть еще вопросы, не стесняйтесь задавать.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос