
Напишите программу на java, которая содержала бы класс, имеющий все основные арифметические методы.


Ответы на вопрос

Ответ:
не забудь оценить )
Объяснение:




Конечно! Вот пример программы на Java, которая содержит класс с основными арифметическими методами:
```java public class ArithmeticOperations { private int number1; private int number2;
// Конструктор класса public ArithmeticOperations(int number1, int number2) { this.number1 = number1; this.number2 = number2; }
// Метод сложения public int add() { return number1 + number2; }
// Метод вычитания public int subtract() { return number1 - number2; }
// Метод умножения public int multiply() { return number1 * number2; }
// Метод деления public double divide() { if (number2 != 0) { return (double) number1 / number2; } else { throw new ArithmeticException("Деление на ноль невозможно."); } }
public static void main(String[] args) { // Создание объекта класса ArithmeticOperations ArithmeticOperations calculator = new ArithmeticOperations(10, 5);
// Вызов методов int sum = calculator.add(); int difference = calculator.subtract(); int product = calculator.multiply(); double quotient = calculator.divide();
// Вывод результатов System.out.println("Сумма: " + sum); System.out.println("Разность: " + difference); System.out.println("Произведение: " + product); System.out.println("Частное: " + quotient); } } ```
Эта программа создает класс `ArithmeticOperations`, который имеет основные арифметические методы: `add` (сложение), `subtract` (вычитание), `multiply` (умножение) и `divide` (деление). Класс также имеет две приватные переменные `number1` и `number2`, которые хранят значения чисел, над которыми выполняются арифметические операции.
В методе `main` программы создается объект класса `ArithmeticOperations` с заданными значениями чисел (в данном случае 10 и 5). Затем вызываются методы класса для выполнения арифметических операций и результаты выводятся на экран.
Надеюсь, это поможет вам создать программу с основными арифметическими методами на Java!


Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili