Вопрос задан 16.06.2023 в 12:42. Предмет Информатика. Спрашивает Цветкова Елена.

Напишите программу в паскале найти сумму и произведение чисел -4 -3 -2 -1 0 1 2

0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Салимов Артём.

Ответ:

Программа написана ниже:

Объяснение:

program H;

var sum, proz : integer;

begin

 sum := (-4) + (-3)+(-2)+(-1)+0+1+2;

 proz := (-4) * (-3)*(-2)*(-1)*0*1*2;

 writeln ('Сумма =', sum);

 writeln ('Произведение =', proz);

end.

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Программа на Паскале для нахождения суммы и произведения чисел -4, -3, -2, -1, 0, 1, 2:

```pascal program SumAndProduct; var numbers: array[1..7] of integer; i, sum, product: integer; begin numbers[1] := -4; numbers[2] := -3; numbers[3] := -2; numbers[4] := -1; numbers[5] := 0; numbers[6] := 1; numbers[7] := 2; sum := 0; product := 1; for i := 1 to 7 do begin sum := sum + numbers[i]; product := product * numbers[i]; end; writeln('Сумма чисел: ', sum); writeln('Произведение чисел: ', product); end. ```

Эта программа создает массив из чисел -4, -3, -2, -1, 0, 1, 2 и затем использует цикл для нахождения их суммы и произведения. Результаты выводятся на экран.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос