Вопрос задан 15.06.2023 в 20:33. Предмет Информатика. Спрашивает Антонова Настя.

! Сделать на языке python. Срочно. 100 баллов Ваша задача по известным двум скоростям (первая в

километрах в час, вторая в метрах в секунду) определить, какая из скоростей больше. Скорости не равны. Вывести на экран соответствующую скорость. Входные данные На вход подаются два целых числа, по одному в строке: - скорость в километрах в час (k); - скорость в метрах в секунду (m). Выходные данные Вывести наибольшую скорость (смотри пример вывода). Примеры № Входные данные 10 1 ; 18 6 Выходные данные 10 kph 6 mps
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Шинкарёва Анна.

Ответ:

k=int(input())

m=int(input())

if k/3.6>m:

   print (k,'kph')

else:

   print (m,'mps')

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Для решения данной задачи на языке Python можно использовать следующий код:

```python def compare_speeds(kph, mps): if kph > mps: return f"{kph} kph" else: return f"{mps} mps"

kph = int(input("Введите скорость в километрах в час: ")) mps = int(input("Введите скорость в метрах в секунду: "))

max_speed = compare_speeds(kph, mps) print("Наибольшая скорость:", max_speed) ```

В этом коде мы определяем функцию `compare_speeds`, которая принимает два аргумента: `kph` (скорость в километрах в час) и `mps` (скорость в метрах в секунду). Функция сравнивает эти две скорости и возвращает наибольшую скорость в соответствующем формате.

Затем мы запрашиваем у пользователя ввод скорости в километрах в час и в метрах в секунду с помощью функции `input`. Значения преобразуются в целые числа с помощью функции `int`.

Далее вызывается функция `compare_speeds` с введенными значениями, и результат выводится на экран с помощью функции `print`.

Пример работы программы: ``` Введите скорость в километрах в час: 10 Введите скорость в метрах в секунду: 1 Наибольшая скорость: 10 kph ```

``` Введите скорость в километрах в час: 18 Введите скорость в метрах в секунду: 6 Наибольшая скорость: 18 kph ```

Примечание: В данном ответе использованы общие знания о программировании на языке Python и логика решения задачи. Информация о синтаксисе и функциях языка Python была взята из поисковых результатов

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос