Вопрос задан 15.06.2023 в 17:43. Предмет Информатика. Спрашивает Драгоев Дима.

1.Заполните массив случайными числами в интервале (0,20). Введите число X и найдете все значения,

равных X. 2. Напишите программу, которая в зависимости от номера месяца выводит времена года. 3. Дан список, а=[1,2,3,4,5,8,11,13,14,16,17]. А) Удалите элемент 8; Б) добавьте в список элемент 22.​
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Шайхутдинов Алмаз.

Решение:

Python

1.

import random

X = int(input())

N_spisok = []

N = 20

for i in range(0, N):

   N_random = random.randint(0, N)

   N_spisok.append(N_random)

print(N_spisok)

for i in N_spisok:

   if i == X:

       print(i)

   else:

       break

2.

time = int(input())

zima = [12, 1, 2]

vesna = [3, 4, 5]

leto = [6, 7, 8]

osen = [9, 10, 11]

if time in zima:

   print('Зима')

elif time in vesna:

   print('Весна')

elif time in leto:

   print('Лето')

else:

   print('Осень')

3.

a = [1, 2, 3, 4, 5, 8, 11, 13, 14, 16, 17]

a.remove(8)

a.append(22)

print(a)

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

1. Для заполнения массива случайными числами в интервале (0,20) можно использовать следующий код на Python:

```python import random

array = [random.randint(0, 20) for _ in range(10)] # создаем массив из 10 случайных чисел x = int(input("Введите число X: ")) # вводим число X

indices_of_x = [i for i in range(len(array)) if array[i] == x] # находим индексы всех значений, равных X values_of_x = [array[i] for i in indices_of_x] # находим сами значения, равные X

print("Индексы значений, равных X:", indices_of_x) print("Значения, равные X:", values_of_x) ```

2. Программа на Python, которая в зависимости от номера месяца выводит время года:

```python month = int(input("Введите номер месяца: "))

if 3 <= month <= 5: print("Весна") elif 6 <= month <= 8: print("Лето") elif 9 <= month <= 11: print("Осень") else: print("Зима") ```

3. Для выполнения задачи А) и Б) с данным списком на Python можно использовать следующий код:

```python a = [1, 2, 3, 4, 5, 8, 11, 13, 14, 16, 17]

# А) Удаление элемента 8 a.remove(8)

# Б) Добавление элемента 22 a.append(22)

print(a) ```

Этот код удалит элемент 8 из списка и добавит элемент 22 в конец списка.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос