Вопрос задан 15.06.2023 в 16:55. Предмет Информатика. Спрашивает Савина Алёна.

Написать в питоне 1) Напишите программу, использующую цикл while, который печатает и печатает N

положительных целых чисел в порядке убывания. 2) Создайте программу, которая вычисляет заданные слова в обратном порядке.​
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Абрамова Катя.

Ответ:

1) n = int(input("Введите число:"))

i=1

while i<=n:

   print(n)

   n = n - 1

----------------------------------------------------------------------------------

2) n = int(input("Введите число:"))

i=1

while i<=n:

   print(i)

   i = i + 1

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно! Вот решение для ваших двух задач на языке Python:

  1. Программа, использующая цикл while, для печати N положительных целых чисел в порядке убывания:
python
def print_numbers_reverse(n): i = n while i > 0: print(i) i -= 1 # Пример использования: N = 10 print_numbers_reverse(N)
  1. Программа для вычисления заданных слов в обратном порядке:
python
def reverse_words(sentence): words = sentence.split() reversed_sentence = " ".join(reversed(words)) return reversed_sentence # Пример использования: input_sentence = "Программа для вычисления заданных слов" reversed_sentence = reverse_words(input_sentence) print(reversed_sentence)

При запуске этих программ вы получите следующий вывод:

  1. Пример вывода для первой программы:
10 9 8 7 6 5 4 3 2 1
  1. Пример вывода для второй программы:
слов заданных вычисления для Программа

Обратите внимание, что вторая программа разделяет слова в предложении с помощью пробелов.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос