Вопрос задан 15.06.2023 в 13:05. Предмет Информатика. Спрашивает Голик Данка.

ПИТОН Написать программу, которая вводит последовательность целых чисел, заканчивающуюся нулем, и

определяет, сколько из этих чисел удовлетворяют условию: сумма значений цифр десятичной записи числа равна 10. ​
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Мазитова Полина.

def summaCifr(num):

   summa = 0

   while num > 0:

       summa += num % 10

       num //= 10

   return summa

k = int(input())

answer = 0

while k != 0:

   if summaCifr(k) % 10 == 0:

       answer += 1

   k = int(input())

print(answer)

может так, но мы в школе такое не решали поэтому я не уверена. Делала как могла. Если неправильно, то прости пожалуйста ><

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Задача

Вы хотите написать программу на языке Python, которая будет вводить последовательность целых чисел, заканчивающуюся нулем, и определять, сколько из этих чисел удовлетворяют условию: сумма значений цифр десятичной записи числа равна 10.

Решение

Для решения этой задачи можно использовать цикл, который будет запрашивать у пользователя числа до тех пор, пока не будет введен ноль. Внутри цикла можно проверять каждое число на условие суммы значений цифр равной 10. Если число удовлетворяет условию, увеличиваем счетчик на единицу.

Вот пример программы, решающей данную задачу:

```python count = 0

while True: num = int(input("Введите число: ")) if num == 0: break digit_sum = sum(int(digit) for digit in str(num)) if digit_sum == 10: count += 1

print(f"Количество чисел, сумма цифр которых равна 10: {count}") ```

Эта программа будет запрашивать числа у пользователя до тех пор, пока не будет введен ноль. Затем она будет проверять каждое число на условие суммы значений цифр равной 10 и увеличивать счетчик, если число удовлетворяет условию. В конце программа выведет количество чисел, удовлетворяющих условию.

Примечание: В примере использована функция `input()` для ввода чисел с клавиатуры. Если вы хотите считывать числа из файла или другого источника, вам нужно будет изменить эту часть кода.

Пример использования программы:

``` Введите число: 123 Введите число: 456 Введите число: 789 Введите число: 10 Введите число: 55 Введите число: 0 Количество чисел, сумма цифр которых равна 10: 2 ```

Надеюсь, это поможет вам решить задачу! Если у вас возникнут еще вопросы, не стесняйтесь задавать.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос