Вопрос задан 15.06.2023 в 04:23. Предмет Информатика. Спрашивает Сутормин Матвей.

Python Условие Из года в год жители планеты Земля переживали за участь Леонардо Ди Каприо,

которому никак не решались дать заветную статуэтку Оскар. При этом его номинировали практически каждый год, и всё безрезультатно! Премия за премией киноакадемики называли лучшим актером кого-то другого, и вот настал день, когда Оскар вручили Ди Каприо. Фанаты актера решили посчитать количество премий, на которых "продинамили" несчастного Лео. Для этого им нужна программа, в которую постоянно вводится номер актера N в рейтинге IMDb. Как только будет введен номер Леонардо ДиКаприо (23) подсчет требуется остановить и вывести на экран фразу: "Лео ждал .... лет" где вместо многоточия - подсчитанное количество премий (лет) K до награждения Ди Каприо. Формат входных данных Последовательность целых чисел, каждое с новой строки, оканчивающаяся числом 23. Гарантируется, что N < 20000000000 и K < 2017. Формат выходных данных Требуется вывести соответствующую фразу. входные данные выходные данные 3 87 15 4 3 23 Лео ждал 5 лет 65 1762 45 36 33 20 1 1 1 74 334 109 3 23 Лео ждал 13 лет
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Шатохина Полина.

Ответ:

summa = 0

x = int(input())

while x != 23:

   summa=summa+1

   x= int(input())

print("Лео ждал",summa,"лет")

Объяснение:

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Python: Решение задачи

Для решения данной задачи нам потребуется написать программу на Python, которая будет считывать последовательность целых чисел до тех пор, пока не будет введено число 23 (номер Леонардо ДиКаприо в рейтинге IMDb). После этого программа должна остановиться и вывести на экран фразу вида "Лео ждал ... лет", где вместо многоточия будет подсчитанное количество премий (лет) K до награждения ДиКаприо.

```python # Считываем входные данные input_data = [] while True: num = int(input()) if num == 23: break input_data.append(num)

# Подсчитываем количество премий K = len(input_data)

# Выводим результат print(f"Лео ждал {K} лет") ```

После написания программы, мы можем использовать её для обработки предоставленных входных данных и получения соответствующих результатов.

Входные данные:

``` 3 87 15 4 3 23 ```

Выходные данные:

``` Лео ждал 5 лет ```

Дополнительные входные данные:

``` 65 1762 45 36 33 20 1 1 1 74 334 109 3 23 ```

Дополнительные выходные данные:

``` Лео ждал 13 лет ```

Теперь у нас есть программное решение для подсчёта времени, которое Леонардо ДиКаприо ждал до получения заветной статуэтки Оскар.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос