Вопрос задан 13.06.2023 в 19:20. Предмет Информатика. Спрашивает Koval Nastya.

напишите программу "Детектор лжи", в которой программа будет рандомно выдавать надпись правда или

ложь на протяжении 4-х попыток срочно пж даю 50 балов пайтон
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Албан Куаныш.

Ответ:

Как-то так

import random

for i in range(4):

   input("Your answer? ")

   print (bool(random.randint(0, 1)))

Объяснение:

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно! Вот простая программа на Python, которая будет рандомно выдавать надпись "Правда" или "Ложь" в течение 4 попыток:

python
import random def detector_lzhi(): for _ in range(4): if random.choice([True, False]): print("Правда") else: print("Ложь") detector_lzhi()

Каждый раз, когда вы запускаете функцию detector_lzhi(), она будет случайным образом выводить либо "Правда", либо "Ложь". В данном примере программа будет выводить результаты четырех попыток подряд. Вы можете изменить это значение, если хотите больше или меньше попыток.

Обратите внимание, что эта программа не является настоящим детектором лжи, а всего лишь случайным генератором результатов. Настоящий детектор лжи требует более сложных алгоритмов и анализа данных.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос