Вопрос задан 12.06.2023 в 13:37. Предмет Информатика. Спрашивает Шандренко Денис.

Составить программу, которая в массиве из 10 элементов, заполненных рандомно числами из промежутка

(1;15) выполнит: 1) поиск минимального и максимального 2) поиск их разности 3) первый элемент заменит на эту разность 4) поиск количества чётных элементов массива.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Осталецький Влад.

# Импорт библиотек

import random

# Создание массива

array = [random.randint(1, 15) for i in range(10)]

# Поиск минимального и максимального элемента

min = array[0]

max = array[0]

for i in range(1, len(array)):

   if array[i] < min:

       min = array[i]

   if array[i] > max:

       max = array[i]

# Поиск разности

difference = max - min

# Замена первого элемента на разность

array[0] = difference

# Поиск количества чётных элементов

count = 0

for i in range(len(array)):

   if array[i] % 2 == 0:

       count += 1

# Вывод массива

print(array)

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Привет! Вот программа на языке Python, которая выполняет все указанные действия:

python
import random # Создаем массив из 10 элементов, заполненных случайными числами от 1 до 15 array = [random.randint(1, 15) for _ in range(10)] # Выводим исходный массив print("Исходный массив:", array) # Поиск минимального и максимального элементов min_element = min(array) max_element = max(array) print("Минимальный элемент:", min_element) print("Максимальный элемент:", max_element) # Поиск разности между минимальным и максимальным элементами difference = max_element - min_element print("Разность между минимальным и максимальным элементами:", difference) # Замена первого элемента на разность array[0] = difference print("Массив после замены первого элемента:", array) # Поиск количества четных элементов массива count_even = sum(1 for num in array if num % 2 == 0) print("Количество четных элементов массива:", count_even)

Программа создает массив из 10 случайных чисел в диапазоне от 1 до 15. Затем она находит минимальный и максимальный элементы массива, вычисляет их разность и заменяет первый элемент на эту разность. В конце программа подсчитывает количество четных элементов в массиве.

Надеюсь, это поможет! Если у тебя есть еще вопросы, не стесняйся спрашивать.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос