Вопрос задан 07.06.2023 в 23:31. Предмет Информатика. Спрашивает Андрееев Алексей.

C++ 1. Написать программу, которая выводит одномерный массив в обратном порядке. 2. Пользователь

вводит длину сторон пятиугольника, каждая сторона заноситься в массив, необходимо вычислить периметр пятиугольника (периметр — сумма всех сторон).
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Субчак Святозар.

Программа, выводящая одномерный массив в обратном порядке:

int main() {

   const int ARRAY_SIZE = 5;

   int arr[ARRAY_SIZE] = {1, 2, 3, 4, 5};

   std::cout << "Original array: ";

   for (int i = 0; i < ARRAY_SIZE; i++) {

       std::cout << arr[i] << " ";

   }

   std::cout << "\nReversed array: ";

   for (int i = ARRAY_SIZE - 1; i >= 0; i--) {

       std::cout << arr[i] << " ";

   }

   return 0;

}

Программа, вычисляющая периметр пятиугольника:

int main() {

   const int NUM_SIDES = 5;

   double sides[NUM_SIDES];

   double perimeter = 0;

   std::cout << "Enter the lengths of the 5 sides of the pentagon:\n";

   for (int i = 0; i < NUM_SIDES; i++) {

       std::cout << "Side " << i + 1 << ": ";

       std::cin >> sides[i];

       perimeter += sides[i];

   }

   std::cout << "The perimeter of the pentagon is " << perimeter << std::endl;

   return 0;

}

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно! Вот решение ваших задач на C++:

  1. Программа, выводящая одномерный массив в обратном порядке:
cpp
#include <iostream> int main() { const int size = 5; // размер массива int array[size]; // объявление массива // заполнение массива std::cout << "Введите элементы массива:\n"; for (int i = 0; i < size; i++) { std::cin >> array[i]; } // вывод массива в обратном порядке std::cout << "Массив в обратном порядке:\n"; for (int i = size - 1; i >= 0; i--) { std::cout << array[i] << " "; } return 0; }
  1. Программа, вычисляющая периметр пятиугольника:
cpp
#include <iostream> int main() { const int size = 5; // количество сторон пятиугольника double sides[size]; // массив для хранения сторон пятиугольника // ввод длины сторон пятиугольника std::cout << "Введите длину сторон пятиугольника:\n"; for (int i = 0; i < size; i++) { std::cin >> sides[i]; } // вычисление периметра пятиугольника double perimeter = 0; for (int i = 0; i < size; i++) { perimeter += sides[i]; } // вывод результата std::cout << "Периметр пятиугольника: " << perimeter << std::endl; return 0; }

Обратите внимание, что в обоих программах я использовал массивы фиксированного размера для удобства. Вы можете изменить размер массива, если требуется работа с большим количеством элементов.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос