Вопрос задан 17.05.2023 в 22:48. Предмет Информатика. Спрашивает Новиченко Ярослав.

Python Дана последовательность из n целых чисел.Запишите все элементы последовательности в

список, а затем выведи только три первых и три последних элемента списка.Формат входных данныхНа первой строке вводится целое n - количество чисел последовательности (6 ≤ n ≤105).Далее вводятся n целых чисел, каждое на новой строке.Формат выходных данныхВыведите на экран через пробел только числа, требуемые по условию задачи
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Амбарцумян Эдик.

Ответ:

data = []

n = int(input())

for i in range(n):

   number = int(input())

   data.append(number)

print(data[:3], data[-3:])

Объяснение:

Когда будете сохранять мой ответ в файл, убедитесь что соблюдается табуляция (отступы если хотите), иначе полезут ошибки

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Вы можете использовать следующий код на языке Python для решения данной задачи:

python
n = int(input()) # Вводим количество чисел последовательности sequence = [] # Создаем пустой список # Вводим n целых чисел и добавляем их в список for _ in range(n): number = int(input()) sequence.append(number) # Выводим первые три и последние три элемента списка result = sequence[:3] + sequence[-3:] print(*result)

Пример работы программы:

Входные данные: 10 1 2 3 4 5 6 7 8 9 10 Выходные данные: 1 2 3 8 9 10

В этом примере мы сначала вводим количество чисел последовательности, затем вводим сами числа по одному на каждой строке. Затем мы создаем пустой список sequence и добавляем в него введенные числа. Наконец, мы формируем список result, состоящий из первых трех и последних трех элементов списка sequence, и выводим его элементы через пробел с помощью print(*result).

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос