
Вопрос задан 08.04.2021 в 15:53.
Предмет Информатика.
Спрашивает Преснова Евгения.
Написать программу.Даны два числа а и б, наибольшее из них умножить на 10, а наименьшее разделить
на 10

Ответы на вопрос

Отвечает Тамуров Максим.
Var a,b: Real;
begin
writeln('Введите a и b');
readln(a,b);
if a>b then
begin
a:=a*10;
b:=b/10;
end;
if a<b then
begin
b:=b*10;
a:=a/10;
end;
if a=b then
begin
b:=b*10;
a:=a*10;
end;
writeln('a: ',a);
writeln('b: ',b);
end.
begin
writeln('Введите a и b');
readln(a,b);
if a>b then
begin
a:=a*10;
b:=b/10;
end;
if a<b then
begin
b:=b*10;
a:=a/10;
end;
if a=b then
begin
b:=b*10;
a:=a*10;
end;
writeln('a: ',a);
writeln('b: ',b);
end.



Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Вот простая программа на языке Python, которая выполняет описанные действия:
pythona = float(input("Введите число a: "))
b = float(input("Введите число b: "))
if a > b:
max_num = a
min_num = b
else:
max_num = b
min_num = a
max_num *= 10
min_num /= 10
print("Наибольшее число, умноженное на 10: ", max_num)
print("Наименьшее число, разделенное на 10: ", min_num)
Эта программа запрашивает у пользователя два числа a
и b
. Затем она определяет, какое из них наибольшее и какое наименьшее, и выполняет соответствующие операции умножения и деления. Наконец, программа выводит результаты.
Пример использования программы:
yamlВведите число a: 12
Введите число b: 5
Наибольшее число, умноженное на 10: 120.0
Наименьшее число, разделенное на 10: 0.5


Топ вопросов за вчера в категории Информатика

Информатика 47

Информатика 33

Информатика 67

Информатика 18

Информатика 25

Информатика 563

Информатика 16
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili