 
Вопрос задан 01.04.2021 в 04:22.
Предмет Информатика.
Спрашивает Кирсанов Дима.
Написать программу с использование оператора Switch, в которой пользователь вводит с клавиатуры
значение воздуха, и видит на экране совет о том, как одеться при такой погоде? Программа на С++. 0
        0
         0
        0
    Ответы на вопрос
 
        Отвечает Pahomov Renat.
                
                   #include <iostream>              
using namespace std;
int main()
{ setlocale(0,"");
int a;
cout<<"введите значение погоды"<<endl;
cout<<"1-тепло"<<endl;
cout<<"2-жарко"<<endl;
cout<<"3-холодно"<<endl;
cout<<"4-колотун"<<endl;
cin>>a;
switch (a)
{
case 1: cout<<"вы можете одеть джинсы и футболку"<<endl; break;
case 2: cout<<"вы можете одеть шорты и майку "<<endl; break;
case 3: cout<<"вы можете одеть штаны и толстовку "<<endl; break;
case 4: cout<<"вы можете одеть куртку и свитер с подштанниками и ватными штанми "<<endl;
break;
}
return 0;
}
                                        using namespace std;
int main()
{ setlocale(0,"");
int a;
cout<<"введите значение погоды"<<endl;
cout<<"1-тепло"<<endl;
cout<<"2-жарко"<<endl;
cout<<"3-холодно"<<endl;
cout<<"4-колотун"<<endl;
cin>>a;
switch (a)
{
case 1: cout<<"вы можете одеть джинсы и футболку"<<endl; break;
case 2: cout<<"вы можете одеть шорты и майку "<<endl; break;
case 3: cout<<"вы можете одеть штаны и толстовку "<<endl; break;
case 4: cout<<"вы можете одеть куртку и свитер с подштанниками и ватными штанми "<<endl;
break;
}
return 0;
}
 0
                    0
                     0
                    0
                 
            Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
                
    Конечно, вот пример кода на C++, который решает эту задачу с помощью оператора Switch:
c#include <iostream>
using namespace std;
int main() {
   int temp;
   cout << "Введите значение температуры воздуха: ";
   cin >> temp;
   switch (temp) {
      case 30:
         cout << "Одевайтесь легко, носите шорты и футболки." << endl;
         break;
      case 20:
         cout << "Носите футболку и штаны или джинсы." << endl;
         break;
      case 10:
         cout << "Оденьте куртку и джинсы." << endl;
         break;
      case 0:
         cout << "Оденьте зимнюю куртку, шапку и перчатки." << endl;
         break;
      default:
         cout << "Для данной температуры не существует рекомендаций по одежде." << endl;
         break;
   }
   return 0;
}
В этой программе пользователю предлагается ввести значение температуры воздуха. Затем программа использует оператор Switch, чтобы выбрать соответствующий совет по одежде, в зависимости от значения температуры. Если значение температуры не соответствует ни одному из кейсов, программа выдаст сообщение об ошибке.
 0
                    0
                     0
                    0
                Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
	- 
			Математика 
- 
			Литература 
- 
			Алгебра 
- 
			Русский язык 
- 
			Геометрия 
- 
			Английский язык 
- 
			Химия 
- 
			Физика 
- 
			Биология 
- 
			Другие предметы 
- 
			История 
- 
			Обществознание 
- 
			Окружающий мир 
- 
			География 
- 
			Українська мова 
- 
			Информатика 
- 
			Українська література 
- 
			Қазақ тiлi 
- 
			Экономика 
- 
			Музыка 
- 
			Право 
- 
			Беларуская мова 
- 
			Французский язык 
- 
			Немецкий язык 
- 
			МХК 
- 
			ОБЖ 
- 
			Психология 
- 
			Физкультура и спорт 
- 
			Астрономия 
- 
			Кыргыз тили 
- 
			Оʻzbek tili 
 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			