Вопрос задан 20.03.2021 в 06:25. Предмет Информатика. Спрашивает Фомин Артём.

Паскаль помогите плезз срочно даю 35 баллов A. Количество чисел в последовательности 0 Имя

входного файла стандартный ввод Имя выходного файла стандартный вывод Ограничение по времени 2 секунды Ограничение по памяти 64 мегабайта Дана последовательность целых чисел, оканчивающаяся нулём. Необходимо найти количество чисел в этой последовательности. Ноль числом последовательности не считается. Формат входных данных Вводится не более, чем 215 целых чисел, каждое из которых не превосходит по модулю (215−1). После последнего числа вводится 0. Формат выходных данных Требуется вывести одно число — количество чисел в последовательности.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Ткаченко Екатерина.
If ((mas[j]>0) and (mas[j+1]<0)) or ((mas[j]<0) and (mas[j+1]>0)) then
Знак поменялся
0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, я помогу вам написать программу на языке Паскаль для решения данной задачи. Вот пример кода, который решает задачу подсчета количества чисел в последовательности:

pascal
program CountNumbers; var number, count: integer; begin count := 0; repeat readln(number); if number <> 0 then count := count + 1; until number = 0; writeln(count); end.

В этом примере мы используем цикл repeat...until, который выполняется до тех пор, пока вводимое число не равно нулю. Внутри цикла мы считываем число и увеличиваем счетчик count на 1, если число не равно нулю. Когда мы достигаем нуля, цикл завершается, и мы выводим значение count, которое и является количеством чисел в последовательности.

Программа будет считывать числа из стандартного ввода и выводить результат в стандартный вывод.

Надеюсь, это поможет вам решить задачу! Если у вас возникнут еще вопросы, пожалуйста, дайте мне знать.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос