Напишите программу на PascalABC для решения задачи: мальчик решил накопить деньги. В первый месяц
он отложил a рублей, а каждый следующий месяц он откладывал на d рублей больше, чем в предыдущий. Сколько рублей мальчик накопит за n месяцев?Ответы на вопрос
ОТВЕТ:
Var a, d, n, i, otv: integer;
begin
read(a,d,n); - ввод всех значений
otv:=a; - в переменную где будет храниться
for i:=1 to n do ответ записываем начальный взнос
begin
a:=a+d; - увеличиваем в цикле взнос
otv:= otv + (a); - добовляем взнос к нашему ответу
end;
writeln(otv); - выводим ответ
end.
Вот пример программы на PascalABC, решающей задачу о накоплении денег:
pascalprogram MoneySaving; var a, d, n, i, total: Integer; begin Write('Введите сумму, которую мальчик отложил в первый месяц (a): '); Readln(a); Write('Введите разницу в сумме между месяцами (d): '); Readln(d); Write('Введите количество месяцев (n): '); Readln(n); total := a; for i := 2 to n do begin a := a + d; total := total + a; end; Writeln('Мальчик накопит ', total, ' рублей за ', n, ' месяцев.'); Readln; end.
Программа запрашивает у пользователя значение a (сумма, которую мальчик отложил в первый месяц), d (разницу в сумме между месяцами) и n (количество месяцев). Затем она использует цикл for для итерации от второго до последнего месяца и вычисляет общую сумму, которую мальчик накопит (total). В конце программа выводит результат на экран.
Обратите внимание, что в этой программе не предусмотрены проверки на корректность введенных данных (например, на отрицательные значения). Если вам нужно обработать такие случаи, вам следует добавить соответствующие проверки и сообщения об ошибке.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
