Вопрос задан 17.03.2021 в 00:27. Предмет Информатика. Спрашивает Санина Лиза.

Составить программу (Turbo Pascal) вычисления величины дохода по вкладу. Процентная ставка (в

процентах годовых) и время хранения (в днях) задаются во время работы программы. Ниже представлен рекомендуемый вид диалога во время работы программы. Данные, вводимые пользователем, выделены жирным шрифтом. Величина вклада (р.) - 25000Срок вклада (дней) - 30Годовая процентная ставка (%) - 12Доход: 252 р. 80 коп.Сумма по окончании срока вклада: 25252 р. 80 коп.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Федів Антон.
Я не экономист и не экстрасенс, так что если именно сама формула подсчета дохода неверна - меняйте сами, я ее просто нашла в интернете.

var
vklad, dohod, summa, stavka: real;
srok: integer;
begin
write('Величина вклада (р.) - ');
readln(vklad);
write('Срок вклада (дней) - ');
readln(srok);
write('Годовая процентная ставка (%) - ');
readln(stavka);
dohod := (vklad*stavka)/(100*365) * srok;
summa := vklad + dohod;
writeln('Доход: ', Trunc(dohod), ' р.', frac(dohod)*100:3:0, ' коп.');
writeln('Сумма по окончании срока вклада: ', Trunc(summa), ' р.', Frac(summa)*100:3:0, ' коп.');
end.
0 0
Отвечает Полякова Алина.
{pascal, консольный ввод}

var
    velichina_vklada, srok_vklada, godovaya_procentnaya_stavka: integer;
    vklad_s_procentami: real;
   
    vklad_s_procentami_rub, vklad_s_procentami_kop: integer;
    dohod_rub, dohod_kop: integer;
   
begin
    write('Величина вклада (р.) - ');
    readln();
    write('Срок вклада (дней) - ');
    readln(srok_vklada);
    write('Годовая процентная ставка (%) - ');
    readln(godovaya_procentnaya_stavka);
   
    vklad_s_procentami := velichina_vklada * ((real(100) + real(godovaya_procentnaya_stavka)*real(srok_vklada)/365)/100);
    dohod_rub := (velichina_vklada - integer(vklad_s_procentami));
    dohod_kop := (velichina_vklada*100 - integer(vklad_s_procentami*100)) mod 100;
   
    vklad_s_procentami_rub := integer(vklad_s_procentami);
    vklad_s_procentami_kop := integer((vklad_s_procentami*100)) mod 100;
   
    writeln('Доход: ', dohod_rub,' р. ', dohod_kop, ' 80 коп.');
    writeln('Сумма по окончании срока вклада: ', vklad_s_procentami_rub, ' р. ', vklad_s_procentami_kop, ' коп.');
end.

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Вот пример программы на языке Turbo Pascal, которая вычисляет величину дохода по вкладу в соответствии с вашими требованиями:

pascal
program DepositIncomeCalculator; var depositAmount, finalAmount, income: real; depositDays: integer; interestRate: real; begin writeln('Программа вычисления величины дохода по вкладу'); write('Величина вклада (р.) - '); readln(depositAmount); write('Срок вклада (дней) - '); readln(depositDays); write('Годовая процентная ставка (%) - '); readln(interestRate); income := (depositAmount * interestRate / 100) * (depositDays / 365); finalAmount := depositAmount + income; writeln('Доход: ', trunc(income), ' р. ', trunc((income - trunc(income)) * 100), ' коп.'); writeln('Сумма по окончании срока вклада: ', trunc(finalAmount), ' р. ', trunc((finalAmount - trunc(finalAmount)) * 100), ' коп.'); readln; end.

При запуске программы она предложит вам ввести необходимые данные, после чего вы получите результат вычислений.

Примечание: Приведенная программа выполняет простой расчет дохода по вкладу на основе указанных данных. Она не учитывает сложный процент или возможные налоги на доходы. Также обратите внимание, что Turbo Pascal является устаревшим языком программирования и не поддерживается в современных операционных системах.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос