Вопрос задан 08.03.2021 в 03:14. Предмет Информатика. Спрашивает Ермаков Роман.

Составить программу. Вывести на экран 10 первых целых чисел кратных 7 pascal. Если правильно

дам ещё баллы.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Сафронов Алексей.

var a,i:integer;

begin

 for a:=14 to 77 do

   begin


   if (a mod 7=0) then

         write(a,' ');

   end;

end.

0 0
Отвечает Бабийчук Валя.

var i,k:integer;

begin

repeat

if i mod 7 = 0 then

begin

k:=k+1;

write (i,'   ')

end;

i:=i+1

until k=10

end.

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно! Вот пример программы на Pascal, которая выводит первые 10 целых чисел, кратных 7:

pascal
program FirstTenMultiplesOfSeven; var count, num: integer; begin count := 0; num := 7; while count < 10 do begin writeln(num); num := num + 7; count := count + 1; end; end.

Эта программа использует переменные count и num. Переменная count отслеживает количество уже выведенных чисел, а переменная num хранит текущее число, которое мы будем выводить на экран. В цикле while мы проверяем, что count меньше 10, и пока это условие истинно, мы выводим значение переменной num, увеличиваем его на 7 и увеличиваем count на 1. Таким образом, мы выводим первые 10 чисел, кратных 7.

Пожалуйста, используйте эту программу и проверьте ее работу. Если у вас возникнут еще вопросы, не стесняйтесь задавать.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос