Вопрос задан 13.02.2021 в 16:45.
Предмет Информатика.
Спрашивает Пилипенко Игорь.
Здравствуйте! Помогите написать программу на Pascal Даны натуральное число n, действительные
числа y1, ... , yn. найти: max(|z1|, ... , |zn|), где zi = yi при |yi| <=2, 0,5 в противном случае.Ответы на вопрос
Отвечает Питонов Григорий.
// PascalABC.NET 3.3, сборка 1634 от 14.02.2018
// Внимание! Если программа не работает, обновите версию!
begin
var n:=ReadInteger('n=');
ReadSeqReal('Введите '+n+' чисел:',n)
.Select(y->Abs(y)<=2?Abs(y):0.5).Max.Println
end.
// Внимание! Если программа не работает, обновите версию!
begin
var n:=ReadInteger('n=');
ReadSeqReal('Введите '+n+' чисел:',n)
.Select(y->Abs(y)<=2?Abs(y):0.5).Max.Println
end.

Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно! Вот пример программы на Pascal, которая решает задачу:
pascalprogram MaxAbsoluteValue; var n, i: integer; y: array[1..100] of real; z, maxAbs: real; begin // Ввод данных writeln('Введите количество элементов (n): '); readln(n); writeln('Введите элементы массива y:'); for i := 1 to n do begin write('y', i, ': '); readln(y[i]); end; // Поиск максимального абсолютного значения maxAbs := 0; for i := 1 to n do begin if abs(y[i]) <= 2 then z := y[i] else z := 0.5; if abs(z) > maxAbs then maxAbs := abs(z); end; // Вывод результата writeln('Максимальное абсолютное значение: ', maxAbs); readln; end.
Программа позволяет пользователю ввести количество элементов n и значения массива y. Затем она итерирует по массиву y и вычисляет z в соответствии с заданными условиями. На каждой итерации программа обновляет переменную maxAbs, если текущее значение z имеет большее абсолютное значение. Наконец, программа выводит найденное максимальное абсолютное значение.
Топ вопросов за вчера в категории Информатика
Информатика 20
Информатика 23
Информатика 21
Информатика 29
Информатика 21
Информатика 20
Информатика 25
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
