Вопрос задан 11.02.2021 в 15:15.
Предмет Информатика.
Спрашивает Медяник Катя.
Составить программу на Паскале сортировки массива по возрастанию
Ответы на вопрос
        Отвечает Esenov Miyrzhan.
                
                   Сортировка методом пузырька:              
              
const n=10;
Var a:array[1..n] of integer; i,j,b:integer;
Begin
for i:=1 to n do read(a[i]);
for i:=1 to n-1 do
for j:=i+1 to n do
if a[j]<a[i] then
begin
b:=a[i];
a[i]:=a[j];
a[j]:=b;
end;
for i:=1 to n do write(a[i],' ');
End.
                                        const n=10;
Var a:array[1..n] of integer; i,j,b:integer;
Begin
for i:=1 to n do read(a[i]);
for i:=1 to n-1 do
for j:=i+1 to n do
if a[j]<a[i] then
begin
b:=a[i];
a[i]:=a[j];
a[j]:=b;
end;
for i:=1 to n do write(a[i],' ');
End.
            Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
                
    Конечно! Вот пример программы на Паскале, которая выполняет сортировку массива целых чисел по возрастанию с использованием алгоритма сортировки пузырьком:
pascalprogram Сортировка_по_возрастанию; const MAX_SIZE = 100; type TArray = array[1..MAX_SIZE] of Integer; var numbers: TArray; n, i, j, temp: Integer; procedure BubbleSort(var arr: TArray; size: Integer); begin for i := 1 to size - 1 do begin for j := 1 to size - i do begin if arr[j] > arr[j + 1] then begin temp := arr[j]; arr[j] := arr[j + 1]; arr[j + 1] := temp; end; end; end; end; begin Write('Введите размер массива: '); Readln(n); WriteLn('Введите элементы массива:'); for i := 1 to n do begin ReadLn(numbers[i]); end; BubbleSort(numbers, n); WriteLn('Отсортированный массив:'); for i := 1 to n do begin WriteLn(numbers[i]); end; end.
Программа запрашивает размер массива (n) и элементы массива от пользователя. Затем она вызывает процедуру BubbleSort, которая выполняет сортировку пузырьком. В конце программа выводит отсортированный массив на экран.
Обратите внимание, что в этом примере предполагается, что массив содержит целые числа и имеет максимальный размер MAX_SIZE. Вы можете изменить эти значения по своему усмотрению.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
	- 
			
Математика
 - 
			
Литература
 - 
			
Алгебра
 - 
			
Русский язык
 - 
			
Геометрия
 - 
			
Английский язык
 - 
			
Химия
 - 
			
Физика
 - 
			
Биология
 - 
			
Другие предметы
 - 
			
История
 - 
			
Обществознание
 - 
			
Окружающий мир
 - 
			
География
 - 
			
Українська мова
 - 
			
Информатика
 - 
			
Українська література
 - 
			
Қазақ тiлi
 - 
			
Экономика
 - 
			
Музыка
 - 
			
Право
 - 
			
Беларуская мова
 - 
			
Французский язык
 - 
			
Немецкий язык
 - 
			
МХК
 - 
			
ОБЖ
 - 
			
Психология
 - 
			
Физкультура и спорт
 - 
			
Астрономия
 - 
			
Кыргыз тили
 - 
			
Оʻzbek tili
 
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			