Вопрос задан 01.12.2020 в 04:53. Предмет Информатика. Спрашивает Ковалёва Саша.

Написать программу, которая считает значение y при любом целом значении x (Паскаль) y = 1/(x+1)^2

0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Аришина Аня.

begin

 Println(1/Sqr(ReadInteger+1))

end.

Примеры:

7

0.015625

-4

0.111111111111111

0

1

-1

Infinity (это означает бесконечность)

0 0
Отвечает Екимова Александра.

program smth;

var x, y : real;

Begin

writeln ('Введите значение x');

readln (x);

y := 1 / sqr(x+1);

if (sqr(x+1) = 0) then

writeln ('Знаменатель = 0')

else

writeln ('Значение y = ', y);

end.

----------------------------------

Или

----------------------------------

program smth;

var x, y : real;

Begin

writeln ('Введите значение x');

readln (x);

if (x <> -1) then

Begin

y := 1 / sqr(x+1);

writeln ('Значение y = ', y)

end

else

writeln ('Знаменатель = 0');

end.


0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос