
Вопрос задан 12.06.2018 в 19:53.
Предмет Информатика.
Спрашивает Pelipenko Nastya.
Дан массив из 10 элементов. Необходимо заполнить его первыми 10 членами арифметической прогрессии с
заданными первым членом прогрессии aa и её разностью p. Формат входных данных С клавиатуры вводятся целые числа aa и pp (−100≤a,p≤100−100≤a,p≤100). Формат выходных данных Требуется вывести содержимое массива после заполнения согласно условию задачи. Элементы должны разделяться пробелами.

Ответы на вопрос

Отвечает Щурова Анна.
Const n=10;
var ar:array[1..n] of integer;
a,p,i:integer;
begin
write('a = ');
readln(a);
write('p = ');
readln(p);
ar[1]:=a;
for i:=2 to n do ar[i]:=ar[i-1]+p;
for i:=1 to n do write(ar[i],' ');
end.
Пример:
a = 2
p = 5
2 7 12 17 22 27 32 37 42 47


Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili