Вопрос задан 12.06.2018 в 14:32. Предмет Информатика. Спрашивает Гангур Максим.

Написать программу на языке Паскаль. program lab8; var n,i,fact:integer; s:real; x,a:real; begin

write('Введите x='); read(x); write('Введите n='); read(n); fact:=3; s:=1/4; a:=1; for i:=1 to n do begin s:=s+(a*sqr(2*i+1))/(fact*sqr(2*i+2)); fact:=fact*(2*i+1); a:=a*x; end; writeln('s=',s:6:3); end. Подскажите где ошибка и что не так
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Неред Екатерина.

Program lab8;
var
n,i,fact:integer; 
x,a,s:real;
begin
write('Введите x=');
readln(x);
write('Введите n=');
readln(n);
fact:=1;
s:=1/4;
a:=1;
for i:=2 to n do
begin
fact:=fact*(2*i-2)*(2*i-1);
a:=a*x;
s:=s+(a*sqr(2*i-1))/(sqr(2*i)*fact);
end;
writeln('s=',s:6:3);
end.

Пример:
Введите x=2
Введите n=5
s= 0.462

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос