Вопрос задан 10.09.2020 в 00:46. Предмет Информатика. Спрашивает Lisovska Marta.

Напишите программу на паскале, которая сообщает нам: -если оценка 3 или 4 или 5 , то "экзамен

сдан" -если оценка 2, то "не сдан", иначе "нет такой оценки"
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, вот пример программы на Pascal, которая выполняет указанные условия:

```pascal program CheckExamResult;

var grade: Integer;

begin writeln('Введите оценку: '); readln(grade);

case grade of 3, 4, 5: writeln('Экзамен сдан'); 2: writeln('Не сдан'); else writeln('Нет такой оценки'); end;

readln; // Для того, чтобы консольное окно не закрывалось сразу end. ```

В данном примере программа запрашивает у пользователя оценку, затем использует оператор `case` для проверки условий:

- Если оценка равна 3, 4 или 5, программа выводит "Экзамен сдан". - Если оценка равна 2, программа выводит "Не сдан". - Во всех остальных случаях программа выводит "Нет такой оценки".

Программа использует оператор `readln` для ввода значения оценки с клавиатуры и `writeln` для вывода результата на экран.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос