Составить программу в Pascal ABC!!!! Help meeee!!! Подготовка к экзамену!!!! В тексте, состоящем
из 3 слов, проверить, есть ли заданное слово и сколько раз оно повторяется. Если такого слова нет, то выдать сообщение.Ответы на вопрос
Вот пример программы на Pascal, которая выполняет проверку наличия заданного слова в тексте и выводит количество его повторений:
program CheckWord; var text: string; word: string; count: integer; begin // Ввод текста и слова для проверки writeln('Введите текст:'); readln(text); writeln('Введите слово для проверки:'); readln(word); count := 0; // Обнуляем счетчик // Разбиваем текст на слова и ищем совпадения while Pos(' ', text) > 0 do begin if Pos(' ', text) = 1 then // Удаляем пробел в начале текста Delete(text, 1, 1) else begin // Извлекаем очередное слово из текста count := count + 1; if Copy(text, 1, Pos(' ', text)-1) = word then count := count - 1; // Уменьшаем счетчик, если слово совпадает Delete(text, 1, Pos(' ', text)); // Удаляем найденное слово из текста end; end; // Проверяем последнее слово (если текст не закончился пробелом) if text = word then count := count - 1; // Выводим результат if count > 0 then writeln('Слово "', word, '" повторяется ', count, ' раз(а) в тексте.') else if count = 0 then writeln('Слово "', word, '" не повторяется в тексте.') else writeln('Введено пустое слово для проверки.'); end.
В этом примере программа запрашивает текст и слово для проверки, затем разбивает текст на слова по пробелам и сравнивает каждое слово с заданным. Если слово совпадает, счетчик увеличивается, если не совпадает, счетчик остается неизменным. Перед проверкой последнего слова программа удаляет возможный пробел в конце текста. По результатам проверки программа выводит соответствующее сообщение.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
