Pascal ABC, очень срочно. 1. Чтобы выявить самого драчливого разбойника, Али-Баба провел
турнир,во время которого каждый его разбойник подрался с каждым из оставшихся. За победу присваивалось-7 очков,за ничью-5,за поражение-2.Написать программу, определяющую победителя. 2. Царевна Несмеяна каждому из претендентов на её руку и сердце задаёт М вопросов. За очень понравившийся ответ 2 балла, за не очень понравившийся - 4, за не очень не понравившийся - 6, за очень не понравившийся - 8. Написать программу, определяющую самого понравившегося (набравшего наим. количество баллов) претендента.Ответы на вопрос
1. Определение победителя турнира разбойников
Для определения победителя турнира разбойников, где каждый разбойник сражается с каждым из остальных, и за победу, ничью и поражение присваиваются определенные очки, можно написать программу на языке Pascal ABC.
```pascal program Tournament;
const MAX_ROBBERS = 10; // Максимальное количество разбойников
var scores: array[1..MAX_ROBBERS] of integer; // Массив для хранения очков i, j, n: integer;
begin // Инициализация массива очков for i := 1 to MAX_ROBBERS do scores[i] := 0;
// Цикл для проведения боев каждого разбойника с остальными for i := 1 to MAX_ROBBERS do begin for j := 1 to MAX_ROBBERS do begin if i <> j then // Разбойник не может сражаться сам с собой begin writeln('Разбойник ', i, ' сражается с разбойником ', j); writeln('Введите результат (1 - победа, 0 - ничья, -1 - поражение): '); readln(n);
// Присвоение очков в зависимости от результата боя case n of 1: scores[i] := scores[i] - 7; 0: scores[i] := scores[i] - 5; -1: scores[i] := scores[i] - 2; end; end; end; end;
// Поиск победителя n := 1; for i := 2 to MAX_ROBBERS do begin if scores[i] < scores[n] then n := i; end;
writeln('Победитель турнира - разбойник ', n); readln; end. ```
Программа начинается с инициализации массива очков для каждого разбойника. Затем она проводит циклы, в которых каждый разбойник сражается с каждым из остальных. Пользователю предлагается ввести результат каждого боя (1 - победа, 0 - ничья, -1 - поражение), и в зависимости от результата присваиваются соответствующие очки. После всех боев программа находит разбойника с наименьшим количеством очков и объявляет его победителем турнира.
2. Определение претендента, понравившегося Царевне Несмеяне
Для определения претендента, который набрал наименьшее количество баллов, можно написать программу на языке Pascal ABC.
```pascal program Princess;
const MAX_CANDIDATES = 10; // Максимальное количество претендентов
var scores: array[1..MAX_CANDIDATES] of integer; // Массив для хранения баллов i, n: integer;
begin // Инициализация массива баллов for i := 1 to MAX_CANDIDATES do scores[i] := 0;
// Цикл для задания вопросов каждому претенденту for i := 1 to MAX_CANDIDATES do begin writeln('Претендент ', i); writeln('Введите оценку ответа (2 - очень понравился, 4 - не очень понравился, 6 - не очень не понравился, 8 - очень не понравился): '); readln(n);
// Присвоение баллов в зависимости от оценки ответа scores[i] := scores[i] + n; end;
// Поиск претендента с наименьшим количеством баллов n := 1; for i := 2 to MAX_CANDIDATES do begin if scores[i] < scores[n] then n := i; end;
writeln('Самый понравившийся претендент - претендент ', n); readln; end. ```
Программа начинается с инициализации массива баллов для каждого претендента. Затем она проводит циклы, в которых Царевна Несмеяна задает вопросы каждому претенденту и получает оценку ответа (2 - очень понравился, 4 - не очень понравился, 6 - не очень не понравился, 8 - очень не понравился). В зависимости от оценки ответа присваиваются соответствующие баллы. После всех вопросов программа находит претендента с наименьшим количеством баллов и объявляет его самым понравившимся претендентом.
Примечание: Обратите внимание, что в обоих программах используется константа `MAX_ROBBERS` (максимальное количество разбойников) и `MAX_CANDIDATES` (максимальное количество претендентов). Вы можете изменить эти значения в соответствии с вашими потребностями.
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
