Вопрос задан 05.09.2020 в 00:03. Предмет Информатика. Спрашивает Murat Moldir.

Помогите написать программу Паскаль: Организуйте массив. Выведите на дисплей значение и индекс

второго положительного элемента.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Для решения данной задачи на языке Паскаль можно организовать массив и вывести на экран значение и индекс второго положительного элемента. Вот пример программы на Паскале, которая решает данную задачу:

```pascal program SecondPositiveElement;

const length = 5;

var array1: array[1..length] of integer; i, count, secondPositiveIndex: integer;

begin // Заполняем массив случайными числами randomize; for i := 1 to length do array1[i] := random(100) - 50;

// Выводим массив на экран writeln('Массив:'); for i := 1 to length do write(array1[i], ' '); writeln;

// Ищем второй положительный элемент count := 0; secondPositiveIndex := -1; for i := 1 to length do begin if array1[i] > 0 then begin count := count + 1; if count = 2 then begin secondPositiveIndex := i; break; end; end; end;

// Выводим значение и индекс второго положительного элемента if secondPositiveIndex <> -1 then writeln('Второй положительный элемент: ', array1[secondPositiveIndex], ', индекс: ', secondPositiveIndex) else writeln('Второго положительного элемента нет.');

readln; end. ```

В данной программе мы создаем массив `array1` размером `length` и заполняем его случайными числами от -50 до 49. Затем мы выводим массив на экран. Далее мы ищем второй положительный элемент в массиве и сохраняем его индекс в переменную `secondPositiveIndex`. Если второй положительный элемент найден, мы выводим его значение и индекс на экран. Если второго положительного элемента нет, выводим соответствующее сообщение.

Примечание: Приведенный код написан на языке Паскаль. Если вам нужно написать программу на языке C++, дайте мне знать, и я предоставлю вам соответствующий код.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос