Написать программу в Turbo pascal Найти 2 максимума из любой последовательности чисел
Ответы на вопрос
Конечно, я могу помочь вам написать программу на Turbo Pascal для поиска двух максимальных элементов в последовательности чисел. Вот пример кода:
```pascal program FindMaxTwo;
const N = 5; // Количество элементов в последовательности
var Numbers: array[1..N] of Integer; Max1, Max2, i: Integer;
begin // Ввод элементов последовательности writeln('Введите ', N, ' чисел:'); for i := 1 to N do readln(Numbers[i]);
// Инициализация максимальных значений Max1 := Numbers[1]; Max2 := Numbers[2];
// Поиск двух максимальных элементов for i := 3 to N do begin if Numbers[i] > Max1 then begin Max2 := Max1; Max1 := Numbers[i]; end else if Numbers[i] > Max2 then Max2 := Numbers[i]; end;
// Вывод результатов writeln('Первый максимум: ', Max1); writeln('Второй максимум: ', Max2);
readln; end. ```
В этой программе мы используем массив `Numbers`, чтобы хранить последовательность чисел. Затем мы инициализируем две переменные (`Max1` и `Max2`), чтобы хранить два максимальных элемента. Далее мы проходим по массиву и обновляем значения `Max1` и `Max2` в соответствии с текущим элементом.
Пожалуйста, помните, что это простой пример, и его можно улучшить, добавив проверки на ввод данных, обработку ошибок и так далее.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
