составьте программу на языке Паскаль. Среди 15 случайных чисел из диапазона (-25;15) найти
количество чисел, делящихся на 5, но не делящихся на 10.Ответы на вопрос
Программа на языке Паскаль для нахождения количества чисел, которые делятся на 5, но не делятся на 10, среди 15 случайных чисел из диапазона (-25;15) может выглядеть следующим образом:
```pascal program CountNumbers;
uses crt;
var i, number, count: integer;
begin randomize; count := 0;
for i := 1 to 15 do begin number := random(41) - 25; // Генерируем случайное число из диапазона (-25;15) writeln('Случайное число:', number);
if (number mod 5 = 0) and (number mod 10 <> 0) then // Проверяем, делится ли число на 5, но не делится на 10 count := count + 1; end;
writeln('Количество чисел, делящихся на 5, но не делящихся на 10:', count);
readln; end. ```
В этой программе мы используем генератор случайных чисел `randomize`, чтобы сгенерировать 15 случайных чисел из диапазона (-25;15). Затем мы проверяем каждое число, используя операторы `mod` для проверки деления на 5 и 10. Если число делится на 5 (number mod 5 = 0) и не делится на 10 (number mod 10 <> 0), то увеличиваем счетчик count на 1.
В конце программы выводится количество чисел, которые удовлетворяют условию (делятся на 5, но не делятся на 10).
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
