Вопрос задан 08.06.2018 в 16:58.
Предмет Информатика.
Спрашивает Назаров Олег.
PascalABC Составьте программу для вычисления значения силы тока I на участке, состоящем из двух
параллельно соединенных резисторов сопротивлением R1 и R2, если напряжение на концах этого участка равно U.Ответы на вопрос
Отвечает Виноградов Фёдор.
//Общее сопротивление сети:
// 1/R = 1/r1 + 1/r2
// 1/R = (r2+r1)/(r2*r1)
// R = r2*r1 / (r2 + r1)
//Закон Ома для участка цепи:
// I = U/R
var
r1,r2,u : integer;
R,I : real;
begin
writeln ('Введите значения сопротивления (r1 r2)');
readln (r1,r2);
writeln ('Укажите напряжение на концах цепи (u)');
readln (u);
R := r2*r1 / (r2 + r1);
I := U/R;
//Фактически можно не использовать переменную R
//А вставить выражение сразу
// I := U/( r2*r1 / (r2 + r1) );
writeln ('Сила тока на участке = ',I);
end.
Топ вопросов за вчера в категории Информатика
Информатика 75
Информатика 35
Информатика 10
Информатика 40
Информатика 22
Информатика 268
Информатика 36
Информатика 29
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
