Напишите программу, которая анализирует, какую цифру нажал пользователь и вывести прописью название
всех цифр, следующих за введенной. В остальных случаях вывести на экран - "Это не цифра!". напишите только тело программы, Нужно сделать через switch и breakОтветы на вопрос
#include <iostream>
#include <cstdlib>
using namespace std;
void Output(void);
char numbers [10] [6] = {"zero", "one", "two", "three", "four", "five", "six", "seven", "eight", "nine"};
int digit;
int main()
{
cout << "Input digit: ";
cin >> digit;
switch(digit)
{
case 0:
Output();
break;
case 1:
Output();
break;
case 2:
Output();
break;
case 3:
Output();
break;
case 4:
Output();
break;
case 5:
Output();
break;
case 6:
Output();
break;
case 7:
Output();
break;
case 8:
Output();
break;
case 9:
cout << "No more digits";
break;
default:
cout << "Input error! This is not a digit";
return 1;
}
return 0;
}
void Output(void)
{
cout << "Next digits are ";
for (int i = digit + 1; i < 10; i++)
cout << numbers [i] << " ";
}
// К сожалению, выравнивание текста и, если можно так выразиться, табуляция не везде корректно сохраняются, то сдвиги где-то отображаются, где-то нет. Поэтому прилагаю .cpp файл

Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
