Вопрос задан 06.06.2018 в 16:25.
Предмет Информатика.
Спрашивает Леонова Вероника.
Программирование на C++ Входные данные Вводятся целые числа a и b. Гарантируется, что a не
превосходит b. Выходные данные Выведите все числа на отрезке от a до b, являющиеся полными квадратами. Если таких чисел нет, то ничего выводить не нужно.Ответы на вопрос
Отвечает Большаков Костя.
#include <iostream>
#include <cmath>
int main() {
int a, b;
std::cin >> a >> b;
for (int i = floor(sqrt(a)); i * i <= b; ++i) {
std::cout << i * i << " ";
}
return 0;
}
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
